Notifiche
Cancella tutti

La consultazione del forum è libera per tutti.

Per poter porre un quesito è invece necessario essere un utente registrato (clicca qui se non lo sei).

Tutti gli utenti che richiedono un supporto, come da REGOLAMENTO, sono caldamente invitati ad allegare un file di esempio con l'indicazione di quello che si desidera ottenere.

[Risolto] Conteggio riposi

Pagina 1 / 3
 
Forum 1
(@mattio-rouge)
Utente Eminente

Ciao a tutti.

Sto aggiornando un template per la gestione degli orari e vorrei creare una formula che mi contasse i riposi (R) e i recuperi riposo (RR) sia per settimana che per totale mese.

Tenete presente che:

Nel file allegato c'è un layout base senza formule.

Nel file reale, esiste un foglio calendario dove cambiando l'anno cambia in automatico tutti i giorni della settimana, i colori, i bordi a lato della D, i numeri della settimana.

La formula deve tenere tenere presente che l'intervallo varia a seconda di dove cominci o finisca la settimana.

Sul lato destro della tabella ci sono due colonne azzurre. Nel file finale lì apparirà un simbolo non un numero (formattazione condizionale già inserita nel file finale).

Nella prima colonna azzurra deve risultare se per ogni settimana (anche a cavallo) ogni persona ha avuto 2 tra R o RR.

Nella seconda colonna più scura deve risultare se a seconda del numero di settimane presenti in quel mese (anche a cavallo) il totale di R e RR sia 2 per settimana (una persona fa un riposo in una settimana, prima colonna da errore, nella seconda settimana fa 2 R e 1 RR, colonna più scura corretta - presumendo che le altre settimane siano corrette, ovviamente).

Il mio problema sta come far capire ad excel che

gli intervalli da prendere in considerazione variano a seconda del numero presente nella riga "n. sett".

Non mi aspetto che mi risolviate tutto, ma già capire come far comprendere la variabile intervalli senza toccare mai più la formula aiuterebbe molto.

So che è complicato ma spero di essere stato chiaro.

Grazie a tutti per l'aiuto.

Mattia

Versione di Excel
Microsoft 365
Sistema operativo
Mac
Quota
Avviatore di Topic Postato : 28/04/2021 17:42
D@nilo
(@dnilo)
Utente Attivo

Ciao

dovresti allegare invece che una griglia vuota il file con un pò di dati e il risultato da ottenere scritto a mano spiegando come ci arriveresti se facessi i calcoli con carta e penna

RispondiQuota
Postato : 28/04/2021 20:29
Forum 1
(@mattio-rouge)
Utente Eminente

@dnilo

Ecco. All'interno del file una riga d'esempio con una spiegazione dell'obiettivo e di come è ora il template.

Spero aiuti di più...

 

RispondiQuota
Avviatore di Topic Postato : 28/04/2021 21:55
gianfranco55
(@gianfranco55)
Utente Fidato

ciao

ho variato il file con formule

che si possono migliorare

se la struttura è quella che vuoi

vediamo di fare le variazioni che ti servono

 

per i conteggi ho usato

=MATR.SOMMA.PRODOTTO((($B$7:$AL$7="R")+($B$7:$AL$7="RR"))*($B$4:$AL$4=E4))

 

RispondiQuota
Postato : 28/04/2021 23:27
Forum 1
(@mattio-rouge)
Utente Eminente

@gianfranco55

per quanto riguarda la parte del controllo del mese ci siamo quasi.

La prima parte della tua formula mi conta quanti R e RR ci sono.

Per concluderla sto cercando una formula che mi conti quanti numeri univoci ci sono nella riga delle settimane e moltiplicarlo per 2 (se la prima parte e questa coincidono, significa che va bene).

Ho trovato questa formula sul supporto microsoft ma quando la inserisco non funziona. In effetti non capisco cosa significhi quel "&GT" dopo la funzione frequenza.

Quello che scrive nella descrizione questo aiuto è esattamente ciò di cui ho bisogno per confrontarlo con quello che mi hai scritto.

 

Per il controllo delle singole settimane invece, non ci siamo. Non funziona.

Grazie mille.

RispondiQuota
Avviatore di Topic Postato : 29/04/2021 16:28
gianfranco55
(@gianfranco55)
Utente Fidato

ciao

cosa vuol dire

Per il controllo delle singole settimane invece, non ci siamo. Non funziona.

mi sembra aver messo il conteggio sia settimanale che mensile

per le settimane basta cambiare E4 con la cella che ti interessa

 

per le settimane

usa

=SOMMA(SE(FREQUENZA(D4:AL4;D4:AL4)>0;1;0))*2

oppure

=MATR.SOMMA.PRODOTTO(1/CONTA.SE(D4:AL4;D4:AL4 & ""))*2

 

anche se tu vuote non ne puoi avere

perciò sarebbe sufficiente

=MATR.SOMMA.PRODOTTO(1/CONTA.SE(D4:AL4;D4:AL4))*2

RispondiQuota
Postato : 29/04/2021 16:52
Forum 1
(@mattio-rouge)
Utente Eminente
Postato da: @gianfranco55

Ho aggiunto questo pezzo alla formula precedente con la variante se ed il conteggio funziona!

=SOMMA(SE(FREQUENZA(D4:AL4;D4:AL4)>0;1;0))*2

 

Al cambiare dell'anno conteggia quante settimane ci sono, le moltiplica per 2 e conta se il totale dei valori R e RR è uguale. Formattazione condizionale per i simboli ed il gioco è fatto. Grazie grazie grazie.

Ora veniamo alla parte della settimana:

la formula che mi hai proposto non varia se ad esempio in una settimana c'è un R ed in quella successiva un RR e due R.

In realtà in tutte le formule di "conteggio delle settimane" va considerata la variabile celle vuote perché ho inserito una formula scarto che riporta gli orari del mese precedente e successivo se la settimana è a cavallo. Quindi riporta da un minimo di 1 ad un massimo di 6 giorni, lasciando le altre caselle vuote.

Ora l'obiettivo è far sì che il risultato che appare nella colonna della settimana deve essere giusto laddove per ogni settimana ci sono 2 R (in quanto l'obiettivo di questa colonna è verificare se ognuno ha fatto i suoi 2 riposi anche se separati, quindi i RR non devono essere considerati perché riferiti ad un'altra settimana).

Il tutto tenendo sempre presente che l'intervallo varia a seconda del calendario di cui sopra.

Al momento ho creato una tabella a parte che somma le R inserendo a mano l'intervallo da prendere in considerazione. Magari occorre sempre questa soluzione intermedia ma va sempre tenuto presente che la somma finale deve contare tanti numeri quante settimane ci sono nel mese (a gen 2022 ci saranno 6 settimane, quest'anno 5).

Ti allego come lo sto facendo funzionare attualmente e quali possono essere i possibili risultati e la formula mensile funzionante (GRAZIE). Spero possa essere più d'aiuto.

RispondiQuota
Avviatore di Topic Postato : 29/04/2021 17:54
Forum 1
(@mattio-rouge)
Utente Eminente

NB

Nel lavorarci mi sono reso conto che i RR non servono nel conteggio della settimana quindi ho variato la richiesta. Volevo precisarlo perché sennò sembra che mi sono dimenticato un pezzo.

RispondiQuota
Avviatore di Topic Postato : 29/04/2021 17:57
gianfranco55
(@gianfranco55)
Utente Fidato

ciao

ora vedo di variare la settimana.

però uso il mio file dove ho sistemato in automatico il num settimana

scriverlo a mano è un a noia 😀 

tra un po lo allego

RispondiQuota
Postato : 29/04/2021 18:04
gianfranco55
(@gianfranco55)
Utente Fidato

ciao

a naso

basta

=SE(RESTO(MATR.SOMMA.PRODOTTO(--($B$7:$AL$7="R"));2)>0;0;1)

 

inverti 1 e 0 se è sbagliato

RispondiQuota
Postato : 29/04/2021 18:12
Forum 1
(@mattio-rouge)
Utente Eminente

Quasi.

Funziona bene sul 2021, ma se cambio l'anno e le settimane si spostano e dovrebbe dare FALSO ('somma non ci sono due R per settimana), non lo fa.

Comunque sei diventato il mio supereroe: Formulaman.

😀

 

RispondiQuota
Avviatore di Topic Postato : 29/04/2021 18:23
gianfranco55
(@gianfranco55)
Utente Fidato

devi usare settimane intere

sia prima che dopo

prova le formule del file che ho allegato

RispondiQuota
Postato : 29/04/2021 19:54
Forum 1
(@mattio-rouge)
Utente Eminente

non c'è l'allegato...

RispondiQuota
Avviatore di Topic Postato : 30/04/2021 09:57
gianfranco55
(@gianfranco55)
Utente Fidato

ciao

devi vedere le formule num.settimana

l'allegato è nel primo post che ho scritto

RispondiQuota
Postato : 30/04/2021 11:45
Forum 1
(@mattio-rouge)
Utente Eminente

@gianfranco55

ho guardato le formule nelle date e nella riga n sett.
La formula come è inserita ora va conteggiare i R (e RR) presenti nelle colonne che hanno il numero uguale alla cella E4 (53).
A parte che non mi è chiaro come posso applicarlo anche alle successive settimane, non è detto che l'anno prossimo ci sia qualcosa nella cella E4 e tutte le altre settimane si spostano a seconda.

Non so se mi sono spiegato...

RispondiQuota
Avviatore di Topic Postato : 30/04/2021 17:51
Pagina 1 / 3
Condividi:

[]
×