fbpx

SE – Scheda tecnica

SCOPO
Testare una condizione definita dall’utente e restituire un risultato se la condizione è VERO, e un altro risultato se la condizione è FALSO
SINTASSI
SE(test; se_vero; [se_falso])
ARGOMENTI DELLA FUNZIONE
  • test – Un valore o un’espressione logica che può essere valutata come VERO o FALSO
  • se_vero – [opzionale] Il valore da restituire quando test è VERO
  • se_falso – [opzionale] Il valore da restituire quando test è FALSO
NOTE DI UTILIZZO

Utilizzate la funzione SE per verificare o valutare determinate condizioni, e quindi reagire in modo diverso a seconda che il test risulti VERO o FALSO.

Per esempio, diciamo che vogliate assegnare “OK” o “KO” agli studenti sulla base del punteggio di un test. In questo caso, è necessario testare il punteggio (per ogni studente) e poi restituire “OK” o “KO”.

Se avete il punteggio in cella C6, e volete testare questo punteggio per vedere se è di almeno 70, potete usare questo:

C6>=70

Questo si traduce come “C6 contiene un valore maggiore o uguale a 70”. Potrà essere VERO o FALSO, a seconda del valore in C6. Quindi fornite un valore che la funzione SE deve restituire se il test è VERO, e un valore da utilizzare se il test è FALSO.

Mettendo tutto insieme, si può usare questa formula:

=SE(C6>=70; "OK"; "KO")

Questa è la formula visualizzata in D6 nell’esempio mostrato più sotto. Quando viene copiato lungo la colonna, si testerà ogni punteggio restituendo il risultato corretto.

Funzioni SE nidificate

Potreste sentire il termine “SE nidificati” o “dichiarazioni SE nidificate”. Questo si riferisce all’uso di più di una funzione SE in modo da poter verificare più condizioni e restituire più risultati possibili. Ogni istruzione SE deve essere attentamente “nidificata” dentro l’altra in modo che la logica sia corretta.

Ad esempio, la seguente formula può essere utilizzata per assegnare un voto piuttosto che un risultato OK/KO:

=SE(C6<70; 5; SE(C6<75; 6; SE(C6<85; 7; SE(C6<95; 8; 10))))

È possibile nidificare fino a 64 funzioni SE. Tuttavia, in generale, per gli scenari più complessi dovreste prendere in considerazione altre funzioni, come la funzione CERCA.VERT o CERCA.ORIZZ, perché possono gestire diverse condizioni in maniera molto più snella.

Operatori logici

Nella costruzione di un test con SE, è possibile utilizzare uno dei seguenti operatori logici:

Operatore di confrontoSignificatoEsempio
=uguale aA1=D1
>maggiore diA1>D1
>=maggiore o uguale aA1>=D1
<minore diA1<D1
<=minore o uguale aA1<=D1
<>diverso daA1<>D1

Note:

  • Se uno degli argomenti della funzione SE viene fornito come matrice, la funzione SE valuterà ogni elemento della matrice
  • Per contare le cose in modo condizionale, utilizzate le funzioni CONTA.SE o CONTA.PIÙ.SE
  • Per sommare le cose in modo condizionale, utilizzate le funzioni SOMMA.SE o SOMMA.PIÙ.SE
LINK AD APPROFONDIMENTI E/O ESEMPI DI UTILIZZO
SCHERMATE ESEMPLIFICATIVE

La funzione SE

LINK ALLA GUIDA IN LINEA DI OFFICE

Aspetta! Potrebbe interessarti anche: