fbpx

SE.ERRORE – Scheda tecnica

SCOPO
Testare se un valore fornito inizialmente restituisce un errore, e se è così, restituire un valore alternativo
SINTASSI
SE.ERRORE(valore; se_errore)
ARGOMENTI DELLA FUNZIONE
  • valore – Il valore, il riferimento o la formula in cui verificare la presenza di un errore
  • se_errore – Il valore da restituire se viene rilevato un errore
NOTE DI UTILIZZO

Utilizzate la funzione SE.ERRORE per intercettare e gestire gli errori prodotti da altre formule o funzioni. SE.ERRORE controlla i seguenti errori: # N/D, #VALORE!, #RIF!, #DIV/0!, #NUM!, #NOME?, o #NULLO!.

Per esempio, se A1 contiene 10, B1 è vuota, e C1 contiene la formula = A1/B1, la seguente formula riuscirà ad intercettare l’errore #DIV/0! che risulterebbe dalla divisione di A1 per B1:

=SE.ERRORE(A1/B1; "Si prega di inserire un valore in B1")

In questo caso, in C1 verrà visualizzato il messaggio “Si prega di inserire un valore in B1” se B1 è vuoto o pari a zero.

Note:

  • Se valore è vuoto, viene valutato come una stringa vuota (“”) e non come un errore
  • Se se_errore viene fornito come una stringa vuota (“”), non viene visualizzato alcun messaggio quando dovesse venire rilevato un errore
  • Se SE.ERRORE viene immesso come formula matriciale, restituisce una serie di risultati con un elemento per ogni cella in valore
SCHERMATE ESEMPLIFICATIVE

 

LINK ALLA GUIDA IN LINEA DI OFFICE