fbpx

O – Scheda tecnica

SCOPO
Testare una serie di condizioni definite dall’utente e restituire VERO se una delle condizioni restituisce VERO e FALSO in caso contrario
SINTASSI
O(logico1; [logico2]; ...)
ARGOMENTI DELLA FUNZIONE
  • logico1 – La prima condizione o valore logico da valutare
  • logico2 – [opzionale] La seconda condizione o valore logico da valutare
NOTE DI UTILIZZO

Utilizzate la funzione O per testare più condizioni allo stesso tempo, fino a 255 condizioni in totale.

Ad esempio, per verificare se il valore in A1 o il valore in B1 sono superiori a 75, utilizzate la seguente formula:

=O(A1>75;B1<75)

O può essere utilizzata per estendere le funzionalità di funzioni come SE. Utilizzando l’esempio precedente, è possibile fornire O come test logico per una funzione SE in questo modo:

=SE(O(A1>75;B1<75); "OK"; "NON OK")

Questa formula restituirà “OK” se il valore in A1 è maggiore di 75 o il valore in B1 è maggiore di 75.

Se si immette sotto forma di formula matriciale, è possibile verificare tutti i valori di un intervallo rispetto ad un’unica condizione. Ad esempio, questa formula matriciale restituisce VERO se qualsiasi cella dell’intervallo A1:A100 è maggiore di 15:

={O(A1:A100>15}

Note:

  • Ogni condizione logica deve poter essere valutata in VERO o FALSO, o essere una matrice o un riferimento che contenga valori logici
  • I valori di testo o le celle vuote forniti come argomenti vengono ignorati
  • La funzione O restituisce #VALORE! se non trova valori logici
SCHERMATE ESEMPLIFICATIVE

La funzione O

ERRORI
  • #VALORE! – Si verifica se uno degli argomenti logico forniti non può essere interpretato come valore numerico o logico.
LINK ALLA GUIDA IN LINEA DI OFFICE