fbpx

#Excel – Come contare le celle che contengono testo

Se avete bisogno di contare il numero di celle che contengono del testo (cioè non numeri, non errori, non vuote), è possibile farlo con la funzione CONTA.SE e un carattere jolly.

Contare celle che contengono testo

Nell’esempio, la cella attiva contiene questa formula:

=CONTA.SE(B3:B9;"*")

Ecco come funziona:

CONTA.SE conta il numero di celle che corrispondono ai criteri forniti. In questo caso, il criterio fornito è il carattere jolly “*”, che corrisponde a qualsiasi numero di caratteri di testo.

Alcune note:

  • I valori logici VERO e FALSO non sono conteggiati come testo
  • I numeri non sono contati da “*” a meno che non siano inseriti come testo
  • Una cella vuota che inizi con un apostrofo (‘) sarà conteggiata

Un’alternativa con VAL.TESTO

Per contare i valori testuali, è inoltre possibile utilizzare MATR.SOMMA.PRODOTTO con la funzione VAL.TESTO in questo modo:

=MATR.SOMMA.PRODOTTO(--VAL.TESTO(intervallo))

Il doppio trattino (chiamato doppio unario) trasforma il risultato di VAL.TESTO (che restituisce valori logici VERO o FALSO) in 1 e 0. MATR.SOMMA.PRODOTTO poi somma questi valori per ottenere il risultato.

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE

Aspetta! Potrebbe interessarti anche: