fbpx

#Excel – Come sommare se le celle contengono sia x che y

Per sommare dei dati se delle celle contengono sia x che y (cioè contengono, ad esempio, “verde” e “blu”, nella stessa cella) è possibile utilizzare la funzione di SOMMA.PIÙ.SE.

Sommare se le celle contengono sia x che y

Nell’esempio mostrato, la formula in F3 è:

=SOMMA.PIÙ.SE(C3:C7;B3:B7;"*verde*";B3:B7;"*blu*")

La formula funziona in questo modo:

La funzione SOMMA.PIÙ.SE si basa sulla logica E e questo comportamento è automatico. Abbiamo solo bisogno di fornire due coppie intervallo/criterio, entrambe operanti sullo stesso intervallo (B3:B7).

Per entrambi i criteri (contiene “verde”, contiene “blu”) usiamo l’asterisco, che è un carattere jolly che corrisponde a “uno o più caratteri”. Abbiamo messo un asterisco all’inizio e uno alla fine, per permettere alla formula di intercettare “verde” e “blu” ovunque essi appaiano nella cella.

Quando entrambi i criteri restituiscono VERO nella stessa cella, SOMMA.PIÙ.SE somma il valore di colonna C.

Si noti che SOMMA.PIÙ.SE non riconosce la differenza tra maiuscole e minuscole.

 

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE
  • Posts not found

Aspetta! Potrebbe interessarti anche: