fbpx

#Excel – Come utilizzare gli zeri di riempimento con il numero della settimana [Quick Tip]

Per riempire i numeri della settimana (o un qualsiasi altro numero) con alcuni zeri di riempimento, è possibile creare una formula che utilizzi la funzione TESTO.

Riempire i numeri della settimna con degli zero

Nell’esempio mostrato, la cella D3 contiene questa formula:

=TESTO(NUM.SETTIMANA(B3;21);"00")

Che restituisce la stringa “07”.

Come funziona questa formula

La funzione TESTO può applicare formati numerici di ogni genere, tra cui valuta, data, percentuale, ecc. Applicando un formato numerico come “00”, “000”, “0000”, è possibile riempire i numeri con degli zeri di riempimento, a seconda delle nostre esigenze. Gli zeri saranno aggiunti solo dove necessario.

Solo formati numerici

La funzione TESTO converte i numeri in testo come un passaggio normale nell’applicazione del formato numerico.

Se dovete concatenare il risultato ad un’altra stringa di testo, questo metodo è il più adatto, ma se dovete semplicemente applicare un “riempimento” visivo a dei numeri destinati a rimanere isolati, ricordate che è possibile applicare un formato numerico personalizzato anche senza l’utilizzo di una formula.

 

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE
  • Posts not found

Aspetta! Potrebbe interessarti anche: