fbpx

#Excel – Come ottenere il nome del giorno da una data

Se avete bisogno di ottenere il nome del giorno (cioè lunedì, martedì, ecc) da una data, ci sono diverse opzioni a seconda delle esigenze.

Visualizzare il giorno della settimana

Volete semplicemente visualizzare il nome del giorno?

Se volete solo visualizzare il nome del giorno, non è necessaria una formula – è possibile utilizzare un formato numerico personalizzato. Selezionate la data, poi aprite la finestra di dialogo “Formato celle” (Ctrl + 1), scegliete personalizzato, e inserite uno di questi formati personalizzati:

"ggg"  // "Lun"
"gggg" // "Lunedì"

Excel visualizzerà solo il nome del giorno, ma lascerà intatto il valore della data.

Volete convertire la data nel nome del giorno?

Se volete convertire il valore data in un valore testuale, è possibile utilizzare la funzione TESTO con un formato numerico personalizzato come “ggg”. La formula può essere simile alla seguente:

=TESTO(B3;"ggg")

La funzione TESTO converte valori in testo utilizzando il formato numerico che fornite. Si noti che la data si perde nella conversione, solo il testo del nome del giorno rimane.

Un modo più flessibile per ottenere il nome del giorno da una data

Se non volete utilizzare una tabella di supporto, è possibile anche abbinare il numero del giorno della settimana al suo nome direttamente nella funzione SCEGLI in questo modo:

=SCEGLI(GIORNO.SETTIMANA(B5);"Do";"Lu";"Ma";"Me";"Gi";"Ve";"Sa")

In questo caso, immettete i nomi dei giorni della settimana come volete vengano restituiti (abbreviati o meno) come argomenti della funzione SCEGLI, dopo il primo. La funzione GIORNO.SETTIMANA recupera il numero del giorno della settimana, e tale numero viene utilizzato per restituire l’n-esimo valore nell’elenco. Questo funziona perché GIORNO.SETTIMANA restituisce un numero 1-7 che corrisponde ad un determinato giorno della settimana. Con le impostazioni predefinite, Domenica = 1 e Sabato = 7. Consultate la scheda tecnica di GIORNO.SETTIMANA per ulteriori informazioni.

Usare la funzione SCEGLI richiede forse un maggior lavoro di impostazione, ma è anche più flessibile, in quanto consente di mostrare una data in tutti i modi che volete (i valori saranno sempre personalizzati a seconda delle vostre esigenze: abbreviati, non abbreviati, in un’altra lingua, ecc.).

 

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE

Aspetta! Potrebbe interessarti anche: