fbpx

#Excel – Come calcolare gli anni tra due date [Quick Tip]

Se volete calcolare il numero di anni tra due date, è possibile utilizzare la funzione FRAZIONE.ANNO, che restituirà un numero decimale rappresentante la frazione di anno tra due date. Ecco alcuni esempi dei risultati che FRAZIONE.ANNO restituisce:

Data inizialeData finaleRisultato di FRAZIONE.ANNO
01/01/201501/01/20161
15/03/197015/09/19766,5
01/01/200015/07/20000,5389
01/06/200025/06/19990,9333

Una volta ottenuto il valore decimale, è possibile arrotondare il numero, se volete. Ad esempio, è possibile arrotondare al numero intero più vicino:

=ARROTONDA(FRAZIONE.ANNO(A1;B1);0)

Potreste anche voler mantenere solo la parte intera del risultato, senza alcun valore frazionario, in modo da contare solo gli anni interi. In questo caso, si può semplicemente racchiudere FRAZIONE.ANNO all’interno della funzione INT:

=INT(FRAZIONE.ANNO(A1;B1))

 

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE
  • Posts not found

Aspetta! Potrebbe interessarti anche: