fbpx

#Excel – Come contare le celle contenenti valori tra due numeri [Quick Tip]

Se avete bisogno di contare il numero di celle in un intervallo che contengono i valori tra due numeri, è possibile farlo con una formula che utilizzi la funzione CONTA.PIÙ.SE.

Contare celle tra due numeri

Nell’esempio qua sopra, la cella attiva contiene questa formula:

=CONTA.PIÙ.SE(C5:C11;">=80"; C5:C11;"<=90")

Come funziona la formula

La funzione CONTA.PIÙ.SE è costruita per contare le celle che soddisfano più criteri. In questo caso, poiché forniamo lo stesso intervallo per entrambi i criteri, ogni cella nell’intervallo deve soddisfare tutti e due i criteri per rientrare nel conteggio.

Usando invece la funzione CONTA.SE

Se si dispone di una versione precedente di Excel che non abbia la funzione CONTA.PIÙ.SE, è possibile utilizzare al suo posto la funzione CONTA.SE in questo modo:

=CONTA.SE(intervallo; ">X")-CONTA.SE(intervallo; ">Y")

Il primo CONTA.SE conta il numero di celle dell’intervallo che sono maggiori o uguali a X (che per definizione comprende anche i valori superiori a Y, poiché Y è maggiore di X). Il secondo CONTA.SE conta il numero di celle con valori superiori a Y. Questo secondo numero viene quindi sottratto dal primo numero, producendo il risultato finale: il numero di celle che contengono valori tra X e Y.

Rendere i criteri variabili

Se come parte dei criteri, volete utilizzare un valore presente in un’altra cella,  utilizzate il carattere di “e commerciale” (&) per concatenarli in questo modo:

=CONTA.SE(intervallo;”>” & A1)

Se il valore nella cella A1 è “5”, il criterio, dopo la concatenazione sarà “> 5”.

 

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE

Aspetta! Potrebbe interessarti anche: