fbpx

#Excel – Come contare le celle che contengono numeri [Quick Tip]

Se avete bisogno di contare il numero di celle che contengono numeri, utilizzate la funzione CONTA.NUMERI.

Contare celle numeriche

Nell’esempio, la cella attiva contiene questa formula:

=CONTA.NUMERI(B3:B7)

Come funziona la formula

CONTA.NUMERI conta il numero di celle dell’intervallo contenenti numeri e restituisce il risultato come un numero.

Per contare il numero di celle di un intervallo che, invece, non contengono numeri, utilizzate questa formula:

=MATR.SOMMA.PRODOTTO(--NON(VAL.NUMERO(B3:B7)))

Questa formula riesce a contare tutte le celle non numeriche, incluse le celle vuote.

Se fosse necessario contare le sole celle testuali di un intervallo (escluse quindi le celle vuote), occorre utilizzare la seguente:

=CONTA.VALORI(B3:B7)-CONTA.NUMERI(B3:B7)

 

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE
  • Posts not found

Aspetta! Potrebbe interessarti anche: