fbpx

#Excel – Come arrotondare un numero a n cifre significative [Quick Tip]

Se avete bisogno di arrotondare un numero ad un (variabile) numero di cifre, è possibile farlo con una elegante formula che utilizza le funzioni ARROTONDA e LOG10.

Arrotondare a n cifre significative

Nell’esempio illustrato, la formula in cella D3 è la seguente:

=ARROTONDA(B3;C3-(1+INT(LOG10(ASS(B3)))))

Come funziona questa formula

Questa può essere una formula intimidatoria se non si dispone di un buon background in matematica, ma cerchiamo di analizzarla passo-passo.

In primo luogo, quando avete una formula come questa, dove una funzione (in questo caso ARROTONDA) avvolge tutte le altre, è spesso utile lavorare dall’esterno verso l’interno. Così, principalmente, questa formula sta arrotondando il valore B3 utilizzando la funzione ARROTONDA:

=ARROTONDA(B3;x)

Dove x è il numero di cifre significative richieste. La parte difficile di questa formula è calcolare x. Questa è una variabile, perché cambierà a seconda del numero da arrotondare. x è calcolato con questa formula:

C3-(1+INT(LOG10(ASS(B3))))

Questa può sembrare complicata, così prima diamo un’occhiata a come la formula ha bisogno di lavorare per gli esempi forniti.

Ricordate che ARROTONDA presenta la seguente sintassi:

ARROTONDA(num; num_cifre)

e che, con questa funzione, il parametro num_cifre negativo lavora sul lato sinistro dei decimali. Così, per arrotondare 1234567 ad un numero crescente di cifre significative, avremmo:

=ARROTONDA(1234567;-6) = 1000000 // 1 cifra significativa
=ARROTONDA(1234567;-5) = 1200000 // 2 cifre significative
=ARROTONDA(1234567;-4) = 1230000 // 3 cifre significative
=ARROTONDA(1234567;-3) = 1235000 // 4 cifre significative

Quindi, il problema principale è come calcolare -6, -5, -4 e così via a seconda del numero che stiamo arrotondando.

La chiave è capire come questi numeri possono essere espressi utilizzando gli esponenti, come in notazione scientifica:

=ARROTONDA(1234567;-6) = 1000000 = 1,0*10^6
=ARROTONDA(1234567;-5) = 1200000 = 1,2*10^6
=ARROTONDA(1234567;-4) = 1230000 = 1,23*10^6
=ARROTONDA(1234567;-3) = 1235000 = 1,235*10^6

Si noti che l’esponente è 6 in tutti i casi, ed è definito con questa formula:

INT(LOG10(ASS(B6)))

Così, il resto della formula sta semplicemente utilizzando il valore dell’esponente calcolato per capire il giusto numero da dare in pasto alla funzione ARROTONDA a seconda del numero di cifre significative desiderate:

=ARROTONDA(1234567;-6) // 1-(1+6) = -6
=ARROTONDA(1234567;-5) // 2-(1+6) = -5
=ARROTONDA(1234567;-4) // 3-(1+6) = -4
=ARROTONDA(1234567;-3) // 4-(1+6) = -3

Così, in sintesi:

  • ASS converte il valore in valore assoluto (positivo)
  • LOG10 ottiene l’esponente, in questo caso 6 con un valore decimale
  • INT taglia fuori la parte decimale dell’esponente
  • La formula utilizza l’esponente e le cifre significative in dotazione per capire il giusto numero di cifre da dare alla funzione ARROTONDA
  • ARROTONDA arrotonda il numero utilizzando il numero di cifre fornite

 

LE SCHEDE TECNICHE DELLE FUNZIONI UTILIZZATE
  • Posts not found

Aspetta! Potrebbe interessarti anche: